2019年9月

博主刚刚新装cnpm镜像之后发现出现404,居然无法安装模块。经过测试只需要删除掉package.json重新npm init就可以正常安装了博主推测应该是因为package里面有什么设置错误了吧

fs.createReadStream【以文件流的方式读取文件】//引入模块 const fs= require('fs'); //流的方式读取文件 var readStream=fs.createReadStream('t1.txt'); //一块一块读取的 var str='';//保存数据 var count=0; readStream.on...

前言今天博主使用flex写个聊天框遇到个奇怪的问题,本来博主是打算聊天框使用flex:1来铺满屏幕,然后超出部分显示滚动条的,少数的时候很满意,可是当信息多了就会超出部分,按照博主的思路来说一半flex:1有剩余的会铺满,有多的会出现在设置overlow之后会出现滚动条。然而却并没有出现,来看看博主的代码。代码父级样式display: flex; fl...

es6现状我们想要用 ES6 语法来写 JavaScript。然而由于我们需要兼容老版本的浏览器,那些浏览器不支持 ES6,我们需要解决这个问题。有一个标准的做法是:写 ES6 代码 → 将所有代码编译成 ES5 的(比如通过 Babel)→ 再将编译后的代码加载到浏览器执行。这可能已经不再是最有效率的方式了。因为用这种方式,我们强制最新的浏览器运行旧...